TANDANA FILEMAKER DATABASE APPLICATION NOTES
Note: These notes are intended for the Tandana technical support person, Anna and Hope. This is not intended for the various Tandana volunteers. Although sections will be useful for the volunteer users.
Note: This document is updated as of 7/11/16 to reflect the additional Netgear router and TP-Link wifi extender as router options that may be used. Other aspects of the document created initially in 2015 may be slightly dated.
Some Definitions
1. Server Computer – This is the MacBook Air new computer obtained by Tandana to be the focal point of all users who are sharing the Tandana database for tracking Ecuador site visit patient information. 
2. Client Computer – These are any computer or other devices used to access the database on the Server computer. These include MacBooks, PC’s, iPads, Android tablets, and even iPhones or Android phones. Because of the small screen sizes, any phone access will be difficult.
3. FileMaker Pro (‘FM’) – is the computer program that allows users to enter, change, etc. data in a reasonably simple manner. FM is a general database utility program that we have customized for Tandana’s needs. We are using version 14 of FM and FMS.
a. Tool used to create and manage a FM Application and database
b. Runs on Apple Mac (OS X v10.9 or 10.10) or Windows (Win 7 or 8) computers.
c. Free one-time 30 day evaluation available for Mac or Windows PC
d. Peer-to-peer sharing is limited to five simultaneous client connections in addition to the host; each client requires a licensed copy of the software.
e. Use FileMaker Server 14 for increased sharing capability.
f. Any computer accessing FileMaker Pro files over a network will need to have a licensed installation of FileMaker Pro 14.
4. FileMaker App and/or Database (‘DB’) – is the actual custom application database created for Tandana’s usage in Ecuador.
5. FileMaker Server (‘FMS’) – is the FM program that allows remote client computers (Mac’s, PC’s, iPads, etc.) to access the shared FM App / Database on the MacBook Air laptop computer.
a. FileMaker Server is server software to share information with groups of FileMaker Pro and FileMaker Go users and to extend solutions to the web.
b. Connect to data hosted on FileMaker Server using any combination of FileMaker Pro, FileMaker Go and FileMaker WebDirect clients.
c. Uses concurrent connections to provide centralized access for FileMaker WebDirect or FileMaker Go users. FileMaker Server includes one built-in concurrent connection. 
d. Use FileMaker WebDirect to run interactive solutions in a web browser on a client computer.
e. Free one-time 30 day evaluation available for Mac or Windows PC
f. IOS, Android or Windows based clients using current versions of Safari, Chrome or Internet Explorer browsers.
6. Filemaker GO
a. Runs on IOS Devices (iPad, iPhones) only (No Android or Windows devices)
b. Free download from iTunes
c. Used to access a FM App via FM Pro or FM Server
d. Has some limitations compared to using FM Pro or a browser on a client computer
e. Requires a connection to either FM Pro or FM Server … means still need to pay for the connections to be used by FM Go
7. Router Related Equipment
a. There are two D-Link small battery powered wifi routers that may be used. 
b. There is one 120 VAC line powered Netgear wifi router that may be used in lieu of the D-Link. It has much better power and range than the D-Link.  It may be directly connected to the server via the Lightning & Ethernet cables.
c. There is also a TP-Link wifi range extender device that can connect to an Ethernet port of the Netgear router and extend the network via the power lines.
d. There is a short note on their proper configuration and setup at the end of this document.



Hope’s MacBook Air Related (the FM Server)
1. The Mac OS has been updated to the current release (as of 9/12/15)
2. Only one user account has been created: Hope Taft with a password of ‘1248’
3. Only the FileMaker Pro and FileMaker Server programs have been installed. All other MacBook programs are the standard ones shipped with the computer.
4. On the account’s ‘Documents’ folder are a number of items downloaded there:
a. Several ‘PDF’ files pertaining to the FileMaker Pro and FileMaker Server programs. These are very detailed but may be of use when in the field.
b. A few ‘PDF’ files associated with the D-Link router.  The router (D-Link or Netgear) is pre-configured with an SSID of ‘Tandana’ and a password of ‘connection’ and should not require any additional set up.
c. A ‘DOCX’ file that contains the FileMaker Pro and Server license keys.
d. A ‘DOCX’ file that is this file.
e. Miscellaneous and other notes.
5. On the Desktop is the ‘FMS 14 Admin Console.webloc’ icon. Double clicking this will start the process of logging on to the Admin Console. (Account ‘fmserver’, password ‘connection’).
6. FileMaker Pro may be started via the Launch Pad
7. Managing FileMaker Databases
a. New FileMaker App DB may be opened in FileMaker Pro (say from a USB thumb drive or another folder on the Mac) via the File menu > Open and then browse to the desired FileMaker file to be opened.
i. Then you may access this FM DB ‘locally’ .. meaning it is not yet set up in the FM Server for shared access by others.
b. Once a new FM DB is loaded into FileMaker Pro it may be uploaded to the FM Server via the File menu > Sharing > Upload To FileMaker Server .. A pop up box opens … enter:
i. Name: ‘fmserver’
ii. Password: ‘connection’
iii. Host Address: ‘Hopes-MacBook-Air.local’
iv. Click ok to upload the file
c. A FileMaker DB may be stored directly to the FMS folder: the ‘Finder’ app  (Go to Computer > Macintosh HD > Library > FileMaker Server > Data > Databases >) and place the file there. You may need to reboot the computer to finish this process.
d. A FileMaker DB may be removed from the server by removing (deleting or moving to another folder) the DB file .. use the ‘Finder’ app to drill down (Go to Computer > Macintosh HD > Library > FileMaker Server > Data > Databases >) to this location to find the file to move or delete. Then reboot the server so that FM Server completes the process. You may also paste this copy of the database file to a USB thumb drive.
e. See the file” fms14_getting_started.pdf” for more info.



WIFI Router
1. The router (D-Link or Netgear)  is the central communications point for the entire Tandana remote Ecuador site computer set up. All computer devices, the server and all client devices communicate via the WIFI signals provided by the WIFI router. 
2. If this router is not working, then none of the client computers will be able to reach the server Tandana DB.
3. It is preconfigured with an SSID of ‘Tandana’ .. so computers should see this in their list of WIFI signals.
4. The password is ‘connection’ (note the lower case).
5. The Router uses both the 2.4 and 5.8 ghz channels.  Testing has just used the 2.4 ghz, but the 5.8 ghz should also be usable.
6. The battery inside the D-Link router has been tested to provide 5 or 6 hours of continuous operation.
a. The battery must be recharged each night. It may be power via a USB cable to an external suitable battery .. see the D-Link manual
7. Note that every computer device connected to the WIFI router must have a unique IP address. But there is one, for the server MacBook computer that must be a specific value of 192.168.0.193.  To check the IP address the server MacBook computer is using, click on the System Preferences icon and then the Network icon to display the WIFI connection name and the IP address assigned.
If not the 192.168.0.193 then see the router details section at the end of this document.

User’s Client Computers 
1. Note: The completion of many of the following steps is dependent on the actual client computer ,, i.e. PC, MacBook, iPad, Android, etc. .. in use.
2. Wait until the server computer is powered up and verified that it is ready to support operations
a. Boot up the client computer
b. Check the internet access and WIFI connection (method varies with the device type). 
i. The WIFI access point is named ‘Tandana’ with a password of ‘connection’.  Connect.
ii. Observe the strength of the WIFI signal (number of ‘bars’, etc.). For no or very minimal WIFI strength, try moving the client computer around some or closer to the router. Proper operation with the server requires a solid and reliable WIFI signal else the connection may be dropped in the middle of using the DB. 
iii. The WIFI communication may be tested by entering the basic server IP address (192.168.0.193) into the browser and pressing enter. The result will be ‘FileMaker Database Server Website’ if all is well.
iv. There are no other Internet sort of operation or connections .. so no Google, etc.
v. Ensure that the computer WIFI is connected to ‘Tandana’ and not something else.

3. To access the Tandana FM App DB via the FM Pro program running on a Windows computer.
a. Launch FileMaker and close any demo’s that start running if it’s your first time.  Also close the Quick Start menu if it comes up.
b. From the File Menu at the top click Open Remote
c. In the Open dialog box, it will probably show View:  Local Hosts.  Pull down that Local Hosts field and change it to Favorite Hosts.
d. Click Add and then enter the favorite Host Address of’ ‘Hopes-MacBook-Air.Local’
e. Click save to save the host and then click it in the list of Favorite Hosts.
f. You should see the list of databases in the right hand pane…scroll to Tandana and double click it to open it.

4. To access the Tandana FM App DB via the FM Pro program running on an iPad tablet:
a. On the left side of the screen, tap Hosts.  (If you don’t see Hosts, something is already open…tap the 2 squares in the top left corner of the screen to shrink the windows…then tap the red X to close anything that’s open)
b. Tap Add Host
c. Enter the Host Address of’ Hopes-MacBook-Air.Local’.  The Host name can be anything descriptive you like. Perhaps ‘Tandana App DB’
d. Tap save.  The system should then show you a list of available databases.  Tandana will be in the list. Tap it to open it and ender the account name and password when prompted. (acnt ‘tandana’ & pw ‘tandana’)

5. To access the Tandana FileMaker App DB via a web browser (Safari, Chrome, Internet Explorer, etc.) from any computer, tablet or phone:
a. Open a web browser, type: “192.168.0.193 /fmi/webd” or “HTTP://192.168.0.193 /fmi/webd” 
b. This will display the Tandana App … click on it to open it for usage.
c. When using the browser to access the Tandana App .. do not use the browser back or forward arrows … this will take you out of the App and you will need to restart
d. The appearance and functions of the Tandana App in a browser is different and inferior than using FM program directly. So it is best used for light duty usage.


FileMaker Database Application
1. Using the Tandana DB
a. Note that you may be asked for an account and password to open the Tandana DB. If so, the account is ‘tandana’ and the password is ‘tandana’ (both lower case).
b. Also note that the number of licensed connections to the FM server is limited. It is recommended that Client computer users select the menu ‘File’ and the ‘Close’ when you do not expect to make use of the Tandana DB for some number of minutes. Users using a browser can just close the browser window.
2. See other documents detailing the Tandana App usage.
FileMaker Server Admin Console
1. It is a FM Server utility that is used to 
a. Monitor overall FM operation from remote client computers (Mac, PC, Tablets, Phones)
b. Do various administrative tasks to set up and control remote access of the database on the server computer
c. Lots of other technical things well beyond our scope to understand and use
2. For Tandana’s remote site usage of FM .. the use of the Admin Console is limited to basic tasks per the following comments:
a. The Admin Console is started via an FMS Admin Console icon on the MacBook server desktop. The account is ‘fmserver’ and the password is ‘connection’. Note: The Admin Console may also be opened from the MacBook server Safari browser via entering https://localhost:16000. See the FM Server “fms14_getting_started.PDF” file for more info on this. 
b. The ‘Status’ option shows some basic info on the FM App / DB Clients computers in use
c. The ‘General Settings’ and then the ‘Connections’ tab shows the maximum number of paid licensed connections available. This does not include the trial copies of FM that may in use by volunteers.
d. Since the number of licensed copies of FM is limited, it may be desired to set the time limit for idle on Web Direct users to some short value. Doing so frees up a FM license for other users when a user sits idle for too long. This is set in the ‘Web Publishing’ option and the ‘FileMaker WebDirect’ tab and the ‘Session Timeout’ box.
e. The ‘Status’ option includes a 1:0 (e.g. Server On / Off) option on the upper right corner. This may be used to stop the server and remote client users access. A pop up box allows a message to be sent to the users (maybe ‘Shutting down in n minutes .. complete your work!!’) and then then number of minutes until the server shuts down. All active users will see this message.
FileMaker Server Admin Console
[image: ]



Remote Site Set Up
1. Scout out the layout of the site and where the various stations (intake, medical, dental, etc.) are to be located. Also consider what client computer devices the volunteers will be using to access the FM App.
2. Locate the router (D-Link or Netgear)  in a central location for the various client computers to be used. Try to avoid any significant metal or thick masonry walls between the router and any of the client computers. Locate it as high as is reasonably possible. Turn on the router. It is preconfigured and no other set up is required.
3. Set up the server computer near by the router so that it will have good WIFI access (or connect the server to the Netgear router through the Lightning / Ethernet cable). Turn on the server computer and log on. 
a. Use the ‘System Preferences’ program and select ‘Network’ to verify the servers ‘Network Name’ (It must be ‘Tandana’ .. which is the router) and the  ‘IP’ address. The ‘IP’ address of the server MacBook must be ‘192.168.0.193’ .  Powering up the server computer first, before any users client computers power up and connect to the WIFI will help ensure this is the IP address. If this is not the IP address, see the comment at the end of this document.
i. Note: The server network connection is different if the cable connection is used to the Netgear router. See the section at the end of this document.
b. The FileMaker Server program is set to automatically start up when the server computer is booted up. This can be verified by starting the FileMaker Server Admin Console and checking the ‘Status’ and other options.
c. The server computer may be used for other tasks but not recommended other than simple things. (So as to not slow down the client computer users of the Tandana App / DB)
d. The server must not ‘go to sleep’, etc. at any time in that this will halt the FM server action.
e. If strange things happen .. try powering the server down and rebooting. This should reset most simple issues. (Remember to verify the WIFI network and IP address.)
4. Notify the various site volunteers that they may start up their computers and begin using the Tandana database App. Visit each site to assist them with their computer’s start up’s.
5. During the site visit operations, be available to help resolve any user problems that crop up.  This would be limited to very basic problems.  Probably things like, restarting the server or FM App, restart the WIFI router, restart the user’s client computer & FM (if they have it on their client computer). Check the client computer’s WIFI signal and connection to the router and server.
6. At the end of the site visit to power down and repack the equipment for travel back to the HQ
After Return from a Remote Site Visit
1. Ensure the batteries in all devices used are recharged overnight
2. Review with the client users any issues or problems that they had. Find corrections or fixes for the next site visit
3. There may be some Tandana App / DB updates that were deferred during the day’s visit. Consider making these updates.
4. Consider doing a backup of the Tandana App / DB to protect the day’s data.
a. The FM Server Admin Console can back up the database per some schedule that you specify.. See the ‘Schedule’ option. This may desirable to enable during the site visit to provide perhaps hourly database backups. This should provide protection in case something really nasty happens to the main database such that you want to return to the last backup copy.
b. You may also find the file’s locations via the Admin Console: Database Server option and then the Folders tab. Then you may use the ‘Finder’ app to drill down (Go to Computer > Macintosh HD > Library > FileMaker Server > Data > Databases >) to this location to find the file. Then you should be able to right click on the file, select copy and then navigate to a USB ‘thumb’ drive and paste a copy of the file there. (Note: I would first ensure no one is using the database by shutting down access.) After doing this, you should be able to open the file on the thumb drive by using FileMaker Pro on any computer (server or client).


WIF Router Equipment Details.
As of 7/11/16, there are a few WIFI Router options to provide client computer access to the MacBook server while at remote Ecuador locations. Note that only the D-Link or Netgear R7000 routers may be used at a time .. not both (without additional configuration of one or the other).
D-Link Router
· The small original battery powered D-Link router (Tandana owns two now) is suitable for locations where there is not 120 VAC power available. Only one of the D-Links may be used at a time.
· It is preconfigured for ‘Lan Sharing’ and an SSID of ‘tandana’ and a password of ‘connection’. No other configuration should be required.
· If you find that the MacBook server is not being assigned the IP address of 192.168.0.193 then the following steps may be used to correct that:

a. Open a web browser (e.g., Safari, Internet Explorer) on any computer using the D-Link WIFI router (but not the server computer  ... since we want to change its IP address assigned). You can enter http://dlinkrouter.local or “http://192.168.0.1” in the browser URL window. This will bring up a D-Link logon window asking for a pass word. Just hit ‘Log In’ (there is no password.)
b. The router’s Current Status is displayed. Double click on the ‘WIFI Clients’ bubble to display the current and historic clients connected to the router.
c. Look for the server MacBook .. will be labeled as ‘MACBOOKAIR-4AEF’.
d. Check the IP … if not 192.168.0.193 then click on the little pencil nearby and change it. Note that no other devices shown can now have the 192.168.0.193 IP address. If you see one, its IP must be changed to something else.
e. If you had to make this IP change .. then you will likely need to reboot the server computer so that it picks up the changed but correct IP address. Double check the server computer’s IP address to verify that it is now the correct 192.168.0.193.
f. Note: this IP address has been ‘reserved’ in the router so this should not be an issue for this MacBook server computer.
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Netgear Router
· New in 2016 is a more powerful Netgear R7000 wifi router. Testing has shown that it easily out performs the D-Link routers WIFI signal range.  However, it does require 120 VAC power and cannot be battery powered.
· It is preconfigured for an SSID of ‘tandana’ and a password of ‘connection’. No other configuration should be required.
· If you find that the MacBook server is not being assigned the IP address of 192.168.0.193 then the following steps may be used to correct that:

· Open a web browser (e.g., Safari, Internet Explorer) on any computer using the Netgear WIFI router (but not the server computer  ... since we want to change its IP address assigned). You can enter “www.routerlogin.net” in the browser URL window. This will bring up a Netgear logon window asking for an account (‘admin’) and a password (‘password’). 
· The router’s Current Status is displayed. Double click on ‘Attached Devices’ to display the current clients connected to the router.
· Look for the server MacBook .. will be labeled as ‘Hopes-Air’ along with its current assigned IP address.
· Check the IP … if not 192.168.0.193 then 
· Click on the ‘Advanced’ tab near the top
· Then click on ‘Setup’ and then ‘LAN Setup’  You should see the display as shown here:
[image: ]
· This shows two main aspects of the configuration needed for Tandana:
· First the ‘IP Address” field was changed from its default to the shown: 192.168.0.1
· Next the ‘Address Reservation’ option was used to add ‘Hopes-Air’ with the required IP of 192.168.0.193. The MAC address must also be specified and it may be copied from the ‘Attached Devices’ (above)
· If you had to make this IP change .. then you will likely need to reboot the server computer so that it picks up the changed but correct IP address. Double check the server computer’s IP address to verify that it is now the correct 192.168.0.193.
· Note: this IP address has been ‘reserved’ in the router so this should not be an issue for this MacBook server computer.
· The MacBook Server may be directly connected to one of the Router’s Ethernet ports via a Lightning adaptor cable and an Ethernet cable. When doing this, it does change the MacBook server’s network connection. If using this router connection:
· Review the MacBook server’s network connection. It will need to be Configure IPv4: of ‘Using DHCP with a manual IP address’. And then specify the IP Address of 192.168.0.193.
· The Netgear router still needs to be setup as described above.
· These should be the only changes needed.

TP-LINK WIFI Range Extender
The TP-Link WIFI Range Extender may be connected to one of the Ethernet ports on the Netgear router to extend the local network via the 120 VAC power lines. Note this does not work with the D-Link battery powered routers.
[bookmark: _GoBack]The TP-Link device has been configured with the SSID of ‘TP-Link’ and a password of ‘connection’. A Client may connect to the ‘TP-Link’ WIFI signal and the operation there after is the same as with the Netgear router.
See the TP-Link’s manual for more information. Note that there is a utility program that must be downloaded from the TP-Link web site in order to make any configuration changes (so be cautious about doing a full reset of the device).

Monitoring WIFI Signal Strength
All phones and laptop computers have a utility program that may be downloaded and used to monitor the WIFI signal strengths at the various stations at a remote Ecuador location used by Tandana. This is strongly recommended to assess how well a given location is likely to function. Note that moving a client device at the location just a little or orienting it a little different can alter a WIFI’s signal strength dramatically. The same thing is true of the routers as well.
See the table below for what is considered to be minimal, good workable WIFI signal levels.

A Quick Look at WIFI Relative Signal Strength Numbers 
Each 3 dBm represents a doubling or halving of signal power. So below, a smaller negative number is better. 
A -70 dBm signal is about ½ the power of a -67 dBm signal for example

	Signal Strength
	Required for

	-30 dBm 
	Max achievable signal strength. The client can only be a few feet from the AP to achieve this. Not typical or desirable in the real world.

	-67 dBm
	Minimum signal strength for applications that require very reliable, timely packet delivery. VoIP/VoWiFi, streaming video

	-70 dBm
	Minimum signal strength for reliable packet delivery. Email, web

	-80 dBm
	Minimum signal strength for basic connectivity. Packet delivery may be unreliable

	-90 dBm
	Approaching or drowning in the noise floor. Any functionality is highly unlikely.








Note: This diagram is specific for the D-Link battery powered router but it really is the same for the Netgear router.
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BATTERY POWERED 

WIFI ROUTER

CONTEXT DIAGRAM OF THE TANDANA COMPUTER CONFIGURATION FOR EACH REMOTE ECUADOR SITE

The FM Application Server / 

Host Computer

The Several Client Computers At Stations

(may be tablet or full laptop computers)

(A WIFI Connection is shown here, but it 

could be an Ethernet cable connection)

WIFI Connections to the 

Server Computer

Notes:

·No data communications to 

outside world

· All equipment is battery 

powered

· The router MUST be installed at 

a central location for each site to 

allow each station’s client device 

to access the server computer.
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